IDE Menu Structure

User Guide ››
Parent Previous Next

IDE Menu Structure.

The main menu is located as a blue column to the left of the IDE and contains almost all the functions available for managing projects and source files, doing editorial changes, searching for texts or symbols, compiling, testing, debugging and much more.


In Start Mode - when the Start Page is visible and no project is currently open - the main menu is not visible. Instead the Start Page Menu Links located on both the left and right part of the Start Page provide easy access to the most essential functions, and especially newcomers may benefit from this to get an easy start.


In Design Mode - when a project is open - the main menu is always visible.


The Main Menu.

The main menu contains menu items, which are grouped and presented as fly-out menus:

The 6 icons represent these fly-out menus:

  • File Menu: Contains file management functionality to create and save projects, source files etc.
  • Edit Menu: Used when editing source code in the current tab-page editor area.
  • Search Menu: Includes routines to find and replace text or search for symbols using the compiler.
  • Compile Menu: Assembles functionality to syntax check, compile, test and debug.
  • License Menu: Administrative tools to create, update and protect information about licenses and keys.
  • Help Menu: Help and Documentation links.


The content of each fly-out menu is described in more detail on their respective pages.


In general a fly-out menu can contain menu items as both text labels and icons as demonstrated here:



All menu items exist as text labels, but the most essential menu items may also have an icon, which can be clicked instead. If an icon is present, the corresponding text label is always positioned right below (or maybe stacked in a column right below to allow for menu resizing). The combination of icons and text labels are especially used for menus related to file management, source code editing, search functionality, compilation and testing.


Some menu items have a shortcut key combination available like Save (Ctrl+S). If a shortcut is available it will be presented as a hint.


To trigger the presentation of a fly-out menu just hover the mouse on an icon, or click the icon, or use a shortcut key combination (e.g. Alt+F).


When a fly-out menu is open, use the mouse or key arrows + Enter to invoke a sub-menu item or icon.


To close a fly-out menu either press the Escape key or move the mouse outside the menu area or click somewhere outside the menu.


Please note:

Menus have a timer controlled behavior which relates to mouse enter/leave events. When the mouse is positioned on a trigger icon, the relevant fly-out menu is presented. When the mouse is moved pretty fast from the trigger icon to the menu, it stays open until the mouse is moved off the menu area, at which is closes by itself. This allows for a menu functionality with very little click-activity.


Pop-up Menus.

The IDE has context sensitive pop-up functionality included for an easy invocation of actions closely related to the area in question.


As an example the Project Explorer can present 3 different pop-up menus. Just select a tree node and right click the mouse. The pop-up menu presented will depend on whether the tree node is a project, a group or a file.


The tab-pages also have a pop-up menu for page functionality, and the text editor has a pop-up menu with functions that relate to the current cursor position.


Pop-up menus can contain both text and icons and they behave very much like fly-out menus.


Drop-down Menus.

The IDE includes a good deal of small buttons with a downward pointing black triangle. When clicked these buttons can open a drop-down menu containing menu items as text only.

Drop-down menus behave very much like pop-up menus.